要求

注意

我们只支持通过conda安装要求的软件包。

Python 2 >= 2.6 或 Python 3 >= 3.3
建议使用开发包(在大多数Linux发行版上为python-devpython-devel)(见下文)。0.6及以前的版本支持Python 2.4。0.8.2及以前的版本支持Python 2.6。对于Python 3,支持3.3之后的版本。
NumPy >= 1.9.1 < 1.11.1
早期版本可以工作,但我们没有测试。
SciPy >= 0.14 < 0.17.1
当前只有稀疏矩阵和特殊函数需要它的支持,但强烈推荐。SciPy > = 0.8可以工作,但早期版本对稀疏矩阵有已知的错误。
BLAS安装(具有Level 3的功能)
  • 推荐:MKL,通过Conda免费安装。
  • 或者,我们建议安装OpenBLAS,其中包含development headers(-dev-devel,具体取决于你的Linux发行版本)。

可选要求

g++(Linux和Windows),clang(OS X)
强烈推荐。Theano可以回退基于NumPy的Python执行模型,但C编译器允许更快的执行。
nose >= 1.3.0
推荐,用于运行Theano的测试套件。
Sphinx >= 0.5.1, pygments
用于构建文档。LaTeXdvipng也是必需的,用于将数学符号显示为图像。
pydot-ng
处理大的gif/images图片。
NVIDIA CUDA驱动程序和SDK
强烈推荐在NVIDIA gpus上生成/执行GPU代码时需要。参见下面的说明。
libgpuarray
在CUDA和OpenCL设备上生成GPU/CPU代码时需要(参见:GpuArray Backend。)