更新Theano

根据你如何安装Theano,选择下面三个部分中的一个。

你应该经常更新,bug会定期修复,新功能的加入甚至更频繁!

稳定安装

以下命令将仅更新Theano:

<sudo> pip install <--user> <--no-deps> theano
  • 对于root安装,请使用sudo
  • user用于用户安装,不需要管理员权限。它将Theano安装在你本地的site-packages中。
  • 当你不想要通过pip安装Theano的依赖性时,使用no-deps当它们已经安装成系统的包时,这是很重要的。

警告

如果你用yum/apt-get安装NumPy/SciPy,用pip/easy_install更新NumPy/SciPy并不总是一个好主意。这可能使Theano因BLAS的问题而崩溃。发布中包含的NumPy/SciPy版本有时与更新版本的BLAS相关联。使用yum/apt-get/pip/easy_install安装NumPy/SciPy开发包时不会与新版本重新一起编译。要解决可能的崩溃,你可以按如下方式清除Theano缓存:

theano-cache clear

安装最前沿的版本

以下命令将更新你的尖端版本的Theano

<sudo> pip install <--user> <--no-deps> git+https://github.com/Theano/Theano.git#egg=Theano
  • 对于root安装,请使用sudo
  • user用于用户安装,不需要管理员权限。它将Theano安装在你本地的site-packages中。
  • 当你不想要通过pip安装Theano的依赖性时,使用no-deps当它们已经安装成系统的包时,这是很重要的。

警告

如果你用yum/apt-get安装NumPy/SciPy,用pip/easy_install更新NumPy/SciPy并不总是一个好主意。这可能使Theano因BLAS的问题而崩溃。发布中包含的NumPy/SciPy版本有时与更快版本的BLAS相关联。使用yum/apt-get/pip/easy_install安装NumPy/SciPy开发包时不会与新版本重新一起编译。要解决可能的崩溃,你可以按如下方式清除Theano缓存:

theano-cache clear

开发人员的安装

要将你的库更新到最新版本,请将目录更改(cd)为你的Theano文件夹,然后执行以下命令:

警告

下面假设你有git的知识,知道如何做rebase。

git pull --rebase